As a dynamic, ever-growing environment, occasional changes are made to the HyperStudio system.

This booklet documents those changes, and provides you with important information about things that are not covered in the HyperStudio Reference manual.

Sound Shop 3.0: There are a few new features that were added to Sound Shop. The first is that whenever you select a portion of the sound wave in the display window, you can then “grab” either edge of the selected area, and drag it to the left or right to adjust just the beginning or end of the range without affecting the other side. If you put the mouse cursor in the middle of a selected range, you can drag the “window” of that selection to the left or right as well.

After much research, we have determined that the ideal record rate in Sound Shop is 26320. This value is in tune with the frequencies at which your computer operates and, as a result, will give you extremely clean sound recordings. If you’re doing some recording and need very high quality, this value is recommended. (Note that you can also get very good quality by using exactly half this value—13160.)

There are two new menu options in the Effects menu. The first is called “Convert.” Selecting “Convert” will effectively cut the size of your sound file in two, by removing every other byte of the sound sample, then halving the sound’s playback rate. The result is that the sound will take up half the room that it did before selecting “Convert.” However, the quality of the sound will be slightly decreased.

The second new option is called “Compliment,” found at the end of the Effects menu. Selecting “Compliment” will invert the area of the sound file you have selected, or, if no range is selected, the entire file. Inverting a sound has the effect of making the loud parts silent and the silent parts loud. (This is different than reversing a sound, which simply rearranges the bytes of the sound, rather than changing them, as “Compliment” does.)

Finally, when you save a file in Sound Shop, you now have some additional options:

Standard: this is the normal HyperStudio Sound Shop sound file format.
Audio Interchange File Format (AIFF): this format is for exchanging sound files with other computers (AIFF is a sound file format, much the way that GIF is a graphic file format). In general, unless you want to use a sound file on another computer, you won’t need to save your files as AIFF.

Audio Interchange File Format, Compressed (AIFC): this format is similar to AIFF, above, except that it allows compression. Again, you probably won’t use this option unless you wish to move a sound to another computer that can load AIFC files.

Resource: by saving a sound file in this format and placing it in the System folder’s Sounds folder, it is available from the Sound Control Panel (part of System 6).

In addition to those four options, when saving an AIFC or Standard sound file, you have two compression options:

Compressed Voice: this option compresses data at the ratio of 8:4 (that is, the data is compressed to 50% of its original size). The resulting file will sound a little rougher than something compressed with the “Compressed music” setting, below.

Compressed Music: this option compresses data at the ratio of 8:3 (that is, the data is compressed to 62% of its original size). It is the suggested rate if you want to compress music.

Note that HyperStudio can load compressed and non-compressed sound files saved in the Standard format.

New commands in HyperStudio: HyperStudio has three new commands.

Remove Stack Disk: this command, found in the File menu, is useful if you’re working on a one-drive system. It gives the computer a chance to close your stack on disk, and organize files, before you change the disk.
For example, if you’re working on a stack and then you need to bring your disk to another computer, you should choose “Remove Stack Disk” so that HyperStudio has a chance to clean up your disk before you work with it elsewhere. It is very important that you select this command before removing your stack disk for use in another computer!

**Title Card:** this command, which is found in the Extras menu, will move the current card to the first card in the stack. This has the effect of making it the “title card,” or the first card that appears when the stack is loaded.

**Clean Memory:** this command, also an Extra, will attempt to clean up your computer’s memory. You may want to choose this option if you receive a “low on memory” warning from HyperStudio. For more information, see the “Low Memory Warning” section, below.

**Low Memory Warning:** HyperStudio keeps track of your remaining free memory as you work on a stack. However, it also keeps a “reserve” memory area. As your stack approaches the maximum size possible, HyperStudio will put up an alert dialog box telling you it is getting low on memory, and suggesting that you save your stack, and re-start HyperStudio. Unless you are attempting to add something very large—like a long recorded sound, for example—you should be able to complete what you’re doing, save the additions, and then quit HyperStudio (and then re-start it, load your stack again, and continue your project).

If you’re running directly off the 3.5” disks, choosing Quit from the File menu will automatically re-start HyperStudio, since there’s no previous program to return to. (If you’re running from a hard disk, then you’ll need to re-start HyperStudio in whatever way you normally would.)

Another option is to select the “Clean Memory” Extra, found in the Extras menu.

A word of explanation: when HyperStudio tells you it has 100k available (for example), that is not an absolute, unbroken piece of memory. It is actually broken up into “chunks,” and as you add clip-art and sounds, edit buttons, and perform other operations, the chunks of memory may get too small to perform certain operations. Restarting the HyperStudio program does some “housecleaning” that re-orders memory into a more usable arrangement. This happens with all computers and programs, but
is just more noticable when your stack reaches the upper size limits.

If you encounter this often enough to inconvenience you, try keeping your stacks a little smaller. You can always check the stack size, and the amount of memory remaining, by choosing “Stack Info” from the Objects menu.

**Fade To Black (Video):** The HyperStudio Reference Manual refers to this special transition as being useful if you have the Apple II Video Overlay Card, and want to have seamless transitions to and from cards with attached videos. As it happens, *all* HyperStudio transitions now handle transitions to video sequences fairly well. In particular, the standard Fade to Black and Fade to White work just fine. Therefore, a separate “Fade to Video (Black)” is not provided in the transition list, so don’t panic if you can’t find it!

**Selector Tool shortcut:** The manual mentions that you can use Shift-TAB as a keyboard shortcut to switch between the browse cursor (the hand), and the universal edit tool (the pointer). If you’re thinking that it would also be neat to have a shortcut for the selector tool (the square dotted line icon in the Tools menu), you’re in luck! Shift-Control-TAB will toggle between the browse mode and the selector tool.

**Text Styles:** When you click in a text field, select a passage of text, or use the pointer or text tools to select an entire graphic object, the subsequent choice of “Text Style” will show you what font, style, size, etc. the selected text is in. This can be useful to quickly see what style was used somewhere in a stack. (Identification, however, does require that the font be available on your system disk.)

However, suppose you wanted to assign one set of style settings from one text field to another. (That is, if you wanted to copy-and-paste the text font, styles [such as bold, italic, etc.] and the color, but not the text itself.) Here’s an easy way:

Select the first text field, and choose “Text Style” from the Options menu (or just press Apple-Y). When the style dialog appears, verify the styles visually, and then choose “Cancel.” Now here’s the trick: if you select a new text field, but this time press Shift-Apple-Y (or hold down the shift key while you select Text Style from the Options menu), the old style will be carried into the style dialog. Clicking on “OK” at this point will
then set the second text field to the style of the first. This can be very useful if you have to change the style settings of several different text fields.

**Double-Clicking to Edit an Object:** HyperStudio lets you edit not only buttons, but the attributes of any object. To edit an object, select the generic edit tool (the pointer), or the specific edit tool for the type of object (text, graphic, or button) from the Tools menu. Then, just double-click on the object with the mouse. A special note, though: As you get more objects on the screen, and they all are re-drawn as you click the mouse, you find the object doesn’t appear to always respond to a double-click. If this happens, try double-clicking a little more slowly. A slower double-click is easier for the system to detect. You can also go to the Control Panel to change the double-click speed that the computer expects.

**SimpleScript** has had one command revised:

“Refresh screen” has been changed to “Erase screen [with expression]”

The optional “with expression” allows you to clear the screen to one of the normal HyperStudio screen colors. Expression should be a number from 0 to 15.

There are two new commands. The first is in the **Objects** menu and replaces the “Redraw object” command:

<table>
<thead>
<tr>
<th><strong>Highlight object</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Syntax</strong></td>
</tr>
<tr>
<td><strong>Example</strong></td>
</tr>
<tr>
<td><strong>Description</strong></td>
</tr>
<tr>
<td><strong>Notes</strong></td>
</tr>
</tbody>
</table>

You may pass this command either the object’s name or card position in *expression1*, and either the card name or ID in *expression2*. Note that the object’s card position value can change depending on the order of objects on the card.
The second new command is in the *Information* menu:

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Get card name into variable</th>
</tr>
</thead>
<tbody>
<tr>
<td>Example</td>
<td>Get card name into location</td>
</tr>
<tr>
<td>Description</td>
<td>This command returns the current card's name in <em>variable</em>.</td>
</tr>
<tr>
<td>Notes</td>
<td>Note that the name of the card returned is not necessarily the card containing the button which triggered the script.</td>
</tr>
</tbody>
</table>

**SimpleScript In-Line Remarks:** You may now place remarks on the same line as program statements:

```
Show message "See Newsies!" with Icon Caution - remind user
For J = 1 to 5
    Beep - make some noise
Next J
```

**SimpleScript Debugger Variable Display:** In addition, the debugger window has a new feature: When displaying variables, sometimes only the beginning of the variable value is shown. For text, you may wish to see more. Simply click the mouse on the value as it's displayed, and a scrolling window will appear with the entire contents shown. This can also be handy to change a variable of any kind during the debugging process. With the display window open, you can edit the value of the variable, and then continue stepping through your program.

**SimpleScript's “Show Message” command:** When using the dialog box for the “Show Message” command, there are certain characters that cannot be used within the text of your message. Specifically, these are the pound sign (#), asterisk (*), and caret (^).

**New “Auto-Record” NBA:** There is a new NBA (New Button Action) on the HyperStudio disk (in the NBA folder). It is the “Auto-Record” NBA, and its purpose is to let you record a sound directly with a button. This is used in stacks such as foreign language, speech therapy, and others, where you want the users to record their voices without having to know anything about how to create a button with HyperStudio.
To use the Auto-Record NBA, you need to first select “Disk Library” in the NBA selection dialog box. Open the NBA folder on the /HyperStudio diskette, and open the file AutoRecord.

When the name appears in the NBA list (it will be the only one there at that point), click on “Use NBA”. A text box will become active, where you will enter some values that will tell the AutoRecord NBA how you want it to function. This line is sometimes called the “command line.” A typical line might look like:

```
+R2 +T10 +D20 my.sound
```

The options are:

+Rn: How many seconds of sound you want to record. In the example, it would record 2 seconds of sound. If you don’t specify a value, it will record 4 seconds worth of sound. You should give some thought to choosing an appropriate value for the record time. If you choose a value that is too short, the person’s words may be cut off. If you choose a too-large value, then you’ll be taking up extra disk space, and in addition, you’ll be recording extra space at the end of the voice sound sample.

+Tn: This is a threshold value, which determines when a certain level of sound will start the actual recording process. Like the HyperStudio tapedeck, AutoRecord first turns the screen border green, meaning it is waiting for you to actually start speaking. When it hears your voice, the screen border turns red, indicating that it is actively recording. This threshold value is used to adjust how much sound is required to actually begin recording. If your computer is electrically noisy, or for any other reason you want to change the sensitivity of the voice activation, you can enter a number between 0 and 127 after the characters “+T” in the command line.

A value of “10” is reasonable, and is shown in the example. Values too high will prevent AutoRecord from ever starting the recording process, or may also “clip” the first part of what you are trying to record. If you don’t specify a value, “32” is used.

+Dn: Delay for time-out. If the threshold value is too high, or the person never starts speaking, AutoRecord might wait forever. The delay
value sets how long (in seconds) you want the green border to remain. If the person doesn’t speak for a period of time that exceeds your delay value, then AutoRecord will automatically return control back to the stack. In the example, the user is given 20 seconds to start speaking once the button is clicked. If you don’t specify this value, it will wait a maximum of four seconds, and then “time out.”

filename: In the example, “my.sound” is the name of the file that will be written to the disk with the recorded sound. A filename must always be included on the command line for AutoRecord. All other values are optional. (If you’re keeping the files as a record of student’s voices, for example, you may want to just use the student’s name and the date.)

FontLoad NBA: the FontLoad NBA now has a special dialog box interface, with a number of options.

To use the FontLoad NBA, click the “Add” button and select fonts that you want to be loaded when the button is clicked. When the button is clicked, all of the fonts listed in the dialog box will be loaded.

In addition, there are several options:

Undo: By clicking this button (which is available after clicking Cut or Clear), you can place the font(s) back into the list that were just removed.

Clear: This option clears all of the fonts from the list. Click Undo to get them back.

Add: By clicking Add, you can add a new font to the list of fonts to be loaded.

Cut: Clicking Cut will remove the font currently highlighted in the list. Click Undo to place the font back in the list.

Edit: This option allows you to edit the pathname of a font in the list. After clicking “Edit,” simply type a new pathname or use the arrow keys
to edit the current pathname, then click “OK.” (Click “Cancel” to discard your changes.)

A final feature in FontLoad is that if you leave the FontLoad font list entirely blank, then FontLoad will prompt the user to specify the font(s) to be loaded when the button is clicked. Although this may not seem to be very practical for the novice stack user, you may find it personally useful to create a stack which could load fonts from other disks “on the fly.”

**Animator NBA:** There are several new features in Animator. The information below explains all of the changes. Note that it’s pretty intuitive and that the NBA hasn’t changed as much as the volume of text below may lead you to believe—if you’re put off by the amount of information below, don’t forget that you can’t hurt anything with the Animator NBA and experimentation is encouraged!

- **EDIT PATH:**

  1. “Edit existing path” (Apple-E):

     The following key-commands can be executed while in the edit path mode:

     Apple-Space: Clears screen to white, leaving only the path on the screen. This helps see the path on a busy (colorful) screen. Pressing Apple-Space again will return to the normal background.

     Apple-R: Reverses the path’s direction. Same function as “Reverse Direction,” below.

     Escape or Apple-period: Cancels any editing done to the path, restoring the previous path definition.

  2. “Create a new path” command (Apple-N):

     If “Create a new path” is selected, pressing Escape key or Apple-period will cancel this operation IF IT IS DONE BEFORE THE MOUSE IS CLICKED.

  3. “Reverse Direction” (Apple-R):
A checkmark is shown if this option is selected. To turn off "Reverse Direction," select it from the menu a second time and the checkmark will go away.

• EDIT GRAPHIC:

1. "Select new graphic" (Apple-G):

   Performs as before, except as noted under "New Graphic Selection Methods," below.

2. "Flip graphic left to right" (Apple-H):

   This will flip the selected graphic horizontally.

3. "Flip graphic top to bottom" (Apple-V):

   This will flip the selected graphic vertically.

   Note: items 2 and 3 are useful if you want to change an animation’s direction. For example, a button over the map of California calls an animation which has a school bus drive from California to New York (left to right). That button can be "copied" and the new button pasted over New York. Then, using the editor window, you can reverse the path’s direction and then flip the graphic left to right (horizontally) to cause the bus to drive back to California.

• PLAYBACK (Apple-P):

The playback can be cancelled at any time by pressing any key or clicking the mouse.

Even if the "Floats over objects" is NOT selected, the animation will still float over objects while playing back in the editor window.

• CANCEL (Apple-period):

   Advanced users do not get the "Do you want to quit?" dialog.

• "Playback rate" line edit control:
The documentation states the playback rates are from “0 to 9”. It is actually 0 to 99. (99 is VERY slow!)

• “Repeat count” line edit control:

“Continuous playback” control has been replaced by this control. Typing a “0” (zero) for repeat count will cause the animation to play back continuously (or until a key is pressed or the mouse clicked, as documented).

• “Record rate” line edit control:

This controls how fast Animator collects data during the record mode. Note that the initial setting is “6”. This control has no purpose unless “Create a new path” has been selected.

This function allows for slowing down the record process for “unsteady hands,” or, if the record rate is “0” (zero), a much smoother animation can be created because more frames per second are being recorded.

Note: This control is available only to advanced users.

• “This color is invisible:”

This command performs as documented, but has some significant features as indicated in “New Graphic Selection Methods,” listed below.

• “Hide background on 1st frame”

Clarification: the color that is “painted” on the background is not the card’s background color. It’s whatever color that’s been selected as the “transparent” color. Note that this color is active, even if the “This color is invisible” checkbox is unselected.

The area that is “painted” will differ depending on whether the Selector Tool was used to get the graphic or the Lasso Tool was used.

If the Selector Tool was used, the entire “square” of the image is painted.

With the Lasso tool, only the image’s shape is painted.
Advanced user options:

When the “Hide background on 1st frame” option is selected, a dialog box appears with two choices, as follows:

- Option 1: “Use selected color:” allows choice of what color will be painted.

- Option 2: “Use card’s background:” uses card’s underlying image. This effectively restores the card’s background and erases any images placed there by previous animation. This is useful for allowing a moving image to stop at a certain point and the next animation to continue moving the image in the same direction, while restoring the underlying background.

Note: Option 2 will restore the ENTIRE FRAME of the graphic, REGARDLESS of the tool used to get the image. This is useful because it’s very hard to line up a second animation to start exactly where the previous animation ended.

- “Loop Back”

Advanced user options:

- Flip graphic left to right: this will flip the graphic horizontally before looping back.

- Flip graphic top to bottom: this will flip the graphic vertically before looping back.

- Toggle “Float over objects”: this will “toggle” the float option. This is useful if you want to create an “orbiting” effect around a graphic object, text field, or whatever.

Note that all three or none of the options can be selected. If you don’t want any of these options, simply click OK and loop back will occur normally.

- “Draw Multiple:” NO CHANGE

- “Float over objects:” NO CHANGE
• New Graphic Selection Methods:

The lasso tool has been implemented. This necessitated a change in the interface for the select graphic dialog.

The choice of which tool to use is made by clicking on the icon you want. The active tool (the one that will be used) is highlighted in yellow (assuming that you are using a normal color set).

Using the Lasso tool not only allows for selecting otherwise hard-to-get graphics, but also treats the selected graphic differently than the Selector tool as noted here:

The lasso acts the same as normal lassoing does. It will “wrap” itself to the graphic, ignoring the “outside” color. This outside color is masked to prevent it from ever showing up in the animation. This allows the “This color is invisible” option to be unselected so that ALL colors will appear in the graphic without having the graphic appear as a box, such as the Selector tool does.

SPECIAL NOTE: If you want the Selector tool to behave like the Lasso tool (that is, “wrapping” to the graphic and masking the outside color), hold down the Apple key while selecting the graphic with the Selector tool. The graphic will then behave just as if it had been selected with the Lasso.

Here’s the new key equivalents you can use when selecting a graphic:

a) Return key: selects graphic from screen.
b) Apple-Return: selects graphic from disk.
c) Tab: toggles between the Lasso and Selector Tools.

d) Escape or Apple-period: return to the Select Graphic dialog (assuming you haven’t already selected a graphic).

NOTE: there’s another feature, while defining an animation path, or even using the lasso. If you hold down the shift key, the screen motion will be
limited (constrained) to perfectly horizontally or vertically, depending on how the mouse is moving when you hold down the shift key.

**Conclusion:** We hope you enjoy all of the new features to HyperStudio 3.1, and enjoy using HyperStudio for many years to come!